[Clamav-devel] 0.98.5-rc1 milter feedback

Shawn Webb swebb at sourcefire.com
Mon Oct 20 11:08:56 EDT 2014


On Thu, Oct 16, 2014 at 10:29 PM, Michael G. Janicki <
m.g.j.janicki at gmail.com> wrote:

>
>
> On 10/16/2014 07:00 PM, Shawn Webb wrote:
> > Anytime. I'll investigate further tomorrow. Do you have any steps for
> > reproduction?
>
> Hmm reproduction is that it just happens.  But, here's how I'm running
> things.  clamav-0.98.5-rc1 running as daemon.  Postfix 2.11.2 running as
> daemon and clamav using clamav-milter to communicate with Postfix via
> Unix socket.  (clamav-milter.conf below).  clamav-milter is not SUID.
> It manages to work with Postfix by being a member of the group which
> can accessthe necessary Postfix files.  I've had it working this way
> for about a year now so I don't think there's anything too strange
> about the setup.
>
> No major changes in the configuration of either ClamAV or Postfix have
> been made recently.  At one point messages were correctly marked with
> X-Virus-Scanned and X-Virus-Status as dictated by the
> "AddHeader Replace" directive in clamav-milter.conf.  At some point
> during the beta development cycle, the headers just stopped being placed
> into messages.  Sorry I can't be more specific as to when it began, but
> I know it was apparent in 20140905.
>
> Thanks again, Shawn.
>
> -- Mike


Hey Mike,

Some stuff came up on Friday, so I wasn't able to take a look at your
issue. I'm going to look at it today. Can you post your clamd.conf, too,
please?

Thanks,

Shawn


More information about the clamav-devel mailing list