[clamav-users] freshclam works for me

Noel Jones njones at megan.vbhcs.org
Tue Jul 3 11:38:59 EDT 2018


I just wanted to chime in and say that freshclam continues to work
fine for me.

I have great sympathy for those having trouble, but I strongly
suspect they are the vocal minority.  I'd complain too if it seemed
unreliable, but it works fine here.

Before any changes are made to freshclam or the procedure to check
for updates, it's important to understand why some sites are
failing, so the right problem can be fixed.

This is a ipv4 site, and I occasionally get ipv6 error messages --
maybe 4 a week.  They don't seem to cause any particular problem.  A
freshclam.config option to disable ipv6 would fix that.  Or maybe a
"protocol {ipv4|ipv6|any}" option.

There are 6 servers here, running various versions of FreeBSD with
clam 0.100.0.   All are set to run freshclam as a daemon (not from
cron) with "checks 15" and "DatabaseMirror db.us.clamav.net".  I
don't mess with freshclam except to check the logs once in a while
for errors, which are rare.

These servers are at various sites with various internet providers,
but all in US/Tennessee.  Maybe my geographic region just happens to
point to a good mirror.

Using Cloudflare changes the dynamics of updates.  I wonder if it
might be better if everyone pointed to db.clamav.net and all the
direct mirrors are dropped.  Let Cloudflare decide what is the
closest POP, that's kinda their job.

Seems like the DNS record is still needed to announce what update is
supposed to be available.

Anyway, thanks for continuing to look at ways to improve this, and
thanks for listening.



  -- Noel Jones


More information about the clamav-users mailing list