[clamav-users] Clamav daemon not found

Aziz azizgstest at gmail.com
Mon Jul 23 04:42:54 EDT 2018


Hi Mark,

No, it seems different to me, I'm attaching the default clamsmtpd.conf .

Here is a sample of the clamd.conf
<https://opensource.apple.com/source/clamav/clamav-158/clamav.Bin/clamav-0.98/etc/clamd.conf.sample.auto.html>
file

Thanks

On Mon, Jul 23, 2018 at 9:38 AM, <mark.lists at thurning-instruments.co.uk>
wrote:

> Hi Aziz,
>
> It looks like your clamd.conf might be called /etc/clamsmtpd.conf so
> crating a symbolic link to it would resolve the issue.
>
> Have a look at /etc/clamsmtpd.conf to confirm it looks like a clamd
> configuration file first.
>
> If it looks correct then the next thing to try would be:
>
> ln -s /etc/clamsmtpd.conf /etc/clamd.conf
>
> Restart chamad ...
>
> Regards
>         Mark.
>
> On 23/07/18 09:26, Aziz wrote:
>
>> Thanks Mark for your feedback.
>>
>> It seems that the file doesn't exist at all, here is the output :
>>
>> /*[root at mail /]#  find /etc -name "*clam*.conf" -print
>> /etc/clamd.d/clamsmtp.conf
>> /etc/freshclam.conf
>> /etc/tnc/clamavimc.conf
>> /etc/mail/clamav-milter.conf
>> /etc/clamsmtpd.conf*/
>>
>> BR
>>
>>
>>
>> On Mon, Jul 23, 2018 at 9:21 AM, <mark.lists at thurning-instruments.co.uk
>> <mailto:mark.lists at thurning-instruments.co.uk>> wrote:
>>
>>     One option to try, as root, run the command:
>>
>>         find /etc -name "*clam*.conf" -print
>>
>>     Most likely the file is in /etc/clamav
>>
>>     Regards
>>              Mark.
>>
>>     On 23/07/18 09:04, Aziz wrote:
>>
>>         Hi users,
>>
>>         I'm trying to install Clamav in my Centos 7 to use it with
>>         Postfix, however I can't get Clamav deamon clamd to run, which
>>         is causing the following error :
>>
>>         /*/var/run/clamd.amavisd/clamd.sock failed, attempt #1: Can't
>>         connect to a UNIX socket /var/run/clamd.amavisd/clamd.sock:
>>         Connection refused*/
>>
>>
>>         When I try to start clamd the system doesn't find it :
>>         /*
>>         [root at mail clamd.d]# systemctl start clamd
>>         Failed to start clamd.service: Unit not found.*/
>>
>>
>>         Also when running clamd from : [root at mail clamd.d]#
>>         /usr/sbin/clamd I got this error :
>>
>>         *ERROR: Can't open/parse the config file /etc/clamd.conf*
>>
>>
>>         The file /etc/clamd.conf doesn't exist .
>>
>>
>>         Anyone has a hint on how to resolve this ?
>>
>>
>>         Thank you
>>
>>
>>         _______________________________________________
>>         clamav-users mailing list
>>         clamav-users at lists.clamav.net <mailto:clamav-users at lists.cla
>> mav.net>
>>         http://lists.clamav.net/cgi-bin/mailman/listinfo/clamav-users
>>         <http://lists.clamav.net/cgi-bin/mailman/listinfo/clamav-users>
>>
>>
>>         Help us build a comprehensive ClamAV guide:
>>         https://github.com/vrtadmin/clamav-faq
>>         <https://github.com/vrtadmin/clamav-faq>
>>
>>         http://www.clamav.net/contact.html#ml
>>         <http://www.clamav.net/contact.html#ml>
>>
>>
>>
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.clamav.net/pipermail/clamav-users/attachments/20180723/3313e026/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: clamsmtpd.conf
Type: application/octet-stream
Size: 1376 bytes
Desc: not available
URL: <http://lists.clamav.net/pipermail/clamav-users/attachments/20180723/3313e026/attachment.obj>


More information about the clamav-users mailing list