[clamav-users] clamav 0.98.4 on Centos4

Greg Folkert greg at donor.com
Fri Jul 4 17:22:28 EDT 2014


FYI, CentOSv4 Support Ended Feb 2012. It is over 2 years out of date. The
newest I've been able to get to work is 0.98.1 with Stock Stuff.

Install/Compile a newer version of OpenSSL in /usr/local/openssl-(version)/
and point your ClamAV compile towards it. That is the only way I could get
0.98.4 to compile and work. I still have other issues though with the
install, all related to the rest of the machine running on openssl
0.9.7a-43.18

Good Luck.


On Fri, Jul 4, 2014 at 3:01 PM, René Bellora <rbellora at tecnoaccion.com.ar>
wrote:

> hi!
>
> I'm trying to compile Clamav 0.98.4 in Centos4, and i get this:
>
> configure: error: Your OpenSSL installation is missing the
> X509_VERIFY_PARAM function. Please upgrade to a more recent version of
> OpenSSL.
>
>
> this is a server that I don't control (I would upgrade Centos otherwise),
> and I'm only allowed to compile and install Clamav. Is there an alternative
> to upgrading openssl?
>
>
> thanks in advance,
> René
> _______________________________________________
> Help us build a comprehensive ClamAV guide:
> https://github.com/vrtadmin/clamav-faq
> http://www.clamav.net/support/ml




-- 
Greg Folkert - Systems Administration and Support
web:   donor.com
email: greg at donor.com
phone: 877-751-3300 x416



More information about the clamav-users mailing list