[clamav-users] clamav 0.98.4 on Centos4

René Bellora rbellora at tecnoaccion.com.ar
Tue Jul 8 11:15:03 EDT 2014


El 04/07/14 18:22, Greg Folkert escribió:
> FYI, CentOSv4 Support Ended Feb 2012. It is over 2 years out of date. The
> newest I've been able to get to work is 0.98.1 with Stock Stuff.
>
> Install/Compile a newer version of OpenSSL in /usr/local/openssl-(version)/
> and point your ClamAV compile towards it. That is the only way I could get
> 0.98.4 to compile and work. I still have other issues though with the
> install, all related to the rest of the machine running on openssl
> 0.9.7a-43.18
>
> Good Luck.



that did work, I'm copying the configures, just in case someone else is 
stuck with Centos4:

I compiled openssl-0.9.8y, only for clam use (it's installed in 
/usr/local/ssl):
./config -fPIC no-gost no-shared no-zlib
make depend
make install

and compiled clam:
./configure --with-openssl=/usr/local/ssl --disable-zlib-vcheck
make
make install



thanks,
René



More information about the clamav-users mailing list