[clamav-users] Problem with ClamAV 0.98.4 - HAVP won't load CVD files

Paul Kosinski clamav at iment.com
Wed Jul 9 12:40:26 EDT 2014


A few days ago, I looked at the ClamAV stuff on GitHub and found the
patch that moved the declarations of cl_initialize_crypto() etc. from
crypto.h to clamav.h.

I then added a call to cl_initialize_crypto() to clamlibscanner.cpp
(see diff below), recompiled and now HAVP starts up properly, and has
been running OK for about 3 days.

I didn't add any call to cl_cleanup_crypto() because it didn't see any
obvious place to put it. I hope that whatever it cleans up (like
memory allocation) will happen automatically when HAVP exits and the
processes terminate.

----------

diff -c havp-0.92b/havp/scanners/clamlibscanner.cpp havp-0.92b/havp/scanners/clamlibscanner.cpp.orig
*** havp-0.92b/havp/scanners/clamlibscanner.cpp		2014-07-06 20:50:59.118992203 -0400
--- havp-0.92b/havp/scanners/clamlibscanner.cpp.orig	2009-03-13 06:35:00.000000000 -0400
***************
*** 27,40 ****
      if (LL>2) cl_debug();
  
  #ifdef CL_INIT_DEFAULT
- 
-     /* PRK 6 Jul 2014 - added to work around ClamAV change */
-     if ( (ret = cl_initialize_crypto()) != 0 )
-     {
-         printf("ClamAV: cl_initialize_crypto() error: %s\n", cl_strerror(ret));
-         return false;
-     }
- 
      if ( (ret = cl_init(CL_INIT_DEFAULT)) != CL_SUCCESS )
      {
          printf("ClamAV: cl_init() error: %s\n", cl_strerror(ret));
--- 27,32 ----

Diff finished.  Wed Jul  9 12:13:10 2014



More information about the clamav-users mailing list