[clamav-users] File::Scan::ClamAV

Chris cpollock at embarqmail.com
Mon Jul 21 23:36:44 EDT 2014


On Mon, 2014-07-21 at 23:08 -0400, Scott Kitterman wrote:
> On Monday, July 21, 2014 21:47:34 Chris wrote:
> > On Sun, 2014-07-20 at 12:52 -0400, Scott Kitterman wrote:
> > > On Sunday, July 20, 2014 07:27:25 Chris wrote:
> > > > On Sun, 2014-07-20 at 13:32 +0200, Matus UHLAR - fantomas wrote:
> > > > > On 19.07.14 21:38, Chris wrote:
> > > > > >Finally I'm about finished with setting up my Ubuntu 14.04 system and
> > > > > >getting everything setup the way it was in the old Mandriva system. I
> > > > > >have both SA and ClamAV running now but I'm missing a module,
> > > > > >File::Scan::ClamAV to interface with SA. Have tried multiple times to
> > > > > >install via CPAN, I'm posted the output at pastebin -
> > > > > >http://pastebin.com/bdurgL6X
> > > > > >
> > > > > >Any ideas anyone? ClamAV has been installed via the Ubuntu software
> > > > > >installer if it makes a difference.
> > > > > 
> > > > > why not using ClamAV with your MTA directly?
> > > > 
> > > > Good morning Matus, I have postfix installed and running, however, the
> > > > only mail that goes through it are the outputs of cronjobs sent to me
> > > > and the forwarding of spam to the address spam at uce.gov . That is
> > > > probably overkill but I installed it so long ago on the old machine that
> > > > it was just 2nd nature to install it again. The mail from my ISP comes
> > > > in via Fetchmail > Procmail and is run through SA prior to getting
> > > > tossed to my inbox.
> > > 
> > > I use clamsmtp (also from the Ubuntu package archive) with postfix, but I
> > > suspect you could configure it as a transparent proxy between fetchmail
> > > and
> > > procmail.  Then the virus scanning would be handled further upstream.
> > > 
> > > Scott K
> > 
> > I looked at this Scott but I don't think I'm techno-savy enough to try
> > it. Any other ideas on how to install this module? After looking at the
> > 't' folder in the source pkg and the errors it looks like it's looking
> > for something it can't find but then again I'm not a perl programmer so
> > I can't be positive.
> 
> I suspect it was never updated for the clamd API changes in 0.95, but I don't 
> know.  I'm not a perl guy either.
> 
> Scott K

I looked at my old syslog from just prior to my crash and I had 98.4
running on the old box but then I assume I've had the module installed
way prior to that since I've been interfacing the two for a long time.






More information about the clamav-users mailing list