[clamav-users] Introducing OpenSSL as a dependency to ClamAV

Al Varnell alvarnell at mac.com
Sun Mar 2 07:09:14 EST 2014


I need to correct myself on this.  The version of OpenSSL that Apple includes in the current OS X is 0.9.8y 5 Feb 2013.  I now see that the previously reported version was add by me from MacPorts.

-Al-

On Feb 28, 2014, at 2:56 AM, Al Varnell <alvarnell at mac.com> wrote:

> 
> On Wed, Feb 26, 2014 at 08:08 AM, Joel Esler (jesler) wrote:
>> On Friday last week I put a blog post up about introducing OpenSSL into the ClamAV ecosystem.  I wanted to make sure everyone saw it, so please have a look at the blog post here:
>> 
>> http://blog.clamav.net/2014/02/introducing-openssl-as-dependency-to.html
> 
> 
> Just thought I'd throw this out from the OS X world.
> 
> OpenSSL was officially deprecated by Apple with OS X 10.7 in favor of Common Crypto and Security Transforms (and you probably all know what that did for them this weekend).  OpenSSL v1.0.1f is still included in the library so I don't anticipate any immediate issues for developers or users, but we'll have to wait for a ClamAV® developer release to be certain and there's no telling how long Apple will continue to include it.  After that I'm sure there will be ports available that can be adapted.



More information about the clamav-users mailing list