[clamav-users] unable to install on Scientific Linux 6.5

Cliff Hayes chayes at afo.net
Mon Oct 13 11:16:33 EDT 2014


I tried to install latest clamav on new Scientific Linux 6.5 box using 
binary and got this error when I tried to do ./configure...

configure: error: OpenSSL not found.
even if I used ./configure --with-openssl=/usr/local/ssl

So then I tried to install using Yum everything works fine if I run 
clamd as root but if I switch it to run as clamav and start clamd this 
happens ...

ERROR: Can't open/parse the config file /usr/local/etc/clamd.conf

... so I created a symlink for clamd.conf then I get this error ...

LibClamAV Error: cli_loaddbdir(): No supported database files found in 
/usr/local/share/clamav
ERROR: Can't open file or directory
Closing the main socket.

It was looking in /var/lib/clamav for the files but is now looking in 
/usr/local/share/clamav

... so I created more symlinks ...

ln -s /var/lib/clamav/bytecode.cvd /usr/local/share/clamav/bytecode.cvd
ln -s /var/lib/clamav/daily.cvd /usr/local/share/clamav/daily.cvd
ln -s /var/lib/clamav/main.cvd /usr/local/share/clamav/main.cvd
ln -s /var/lib/clamav/mirrors.dat /usr/local/share/clamav/mirrors.dat

... and got this error when starting clamd ...

LibClamAV Error: Can't load /usr/local/share/clamav/bytecode.cvd: Can't 
allocate memory
LibClamAV Error: cli_loaddbdir(): error loading database 
/usr/local/share/clamav/bytecode.cvd
ERROR: Can't allocate memory
Closing the main socket.

... even though there was plenty of memory.  And if I try to go back to 
running as clamav I get the same error.

So I'm stuck.  Help!
Thanks in advance.




More information about the clamav-users mailing list