[clamav-users] unable to install on Scientific Linux 6.5

Cliff Hayes chayes at afo.net
Mon Oct 13 14:07:16 EDT 2014


openssl-devel was not installed.
installed and re-attempted binary installation.
I see the following 3 problems when using the following configure even 
though I told it where the libncurses and bz2 locations were:
./configure --with-xml=/usr/lib64 --with-libncurses-prefix=/lib64 
--without-libpdcurses-prefix --with-libcurl=/usr/lib64 
--with-libbz2-prefix=/usr/bin

checking how to link with libbz2... -lbz2
checking for BZ2_bzDecompressInit in -lbz2... no
checking bzlib.h usability... no
checking bzlib.h presence... no
checking for bzlib.h... no
configure: WARNING: ****** bzip2 support disabled

checking ncurses/ncurses.h usability... no
checking ncurses/ncurses.h presence... no
checking for ncurses/ncurses.h... no
configure: unable to compile/link with ncurses
checking ncurses.h usability... no
checking ncurses.h presence... no
checking for ncurses.h... no
configure: unable to compile/link with ncurses
checking curses.h usability... no
checking curses.h presence... no
checking for curses.h... no
configure: unable to compile/link with pdcurses
configure: WARNING: ****** not building clamdtop: ncurses not found
checking for libcurl installation... configure: WARNING: libcurl not 
found. Please use the web interface for submitting FPs/FNs.

checking for g++... no
checking for c++... no
checking for gpp... no
checking for aCC... no
checking for CC... no
checking for cxx... no
checking for cc++... no
checking for cl.exe... no
checking for FCC... no
checking for KCC... no
checking for RCC... no
checking for xlC_r... no
checking for xlC... no
checking whether the C++ compiler works... no
configure: error: in `/software/clamav-0.98.4/libclamav/c++':
configure: error: C++ compiler cannot create executables


Regarding your question about where did I install the yum package from:
I'm not sure which repo the package came from.
I have the following installed:
atrpms, elrepo, epel, epel-testing, rpmforge, sl6x, sl-other, sl


On 10/13/2014 10:30 AM, Bryan Burke wrote:
> On Mon, Oct 13, 2014 at 10:19:13AM -0500, Cliff Hayes wrote:
>> (I forgot to mention that OpenSSL is installed)
>>
>> I tried to install latest clamav on new Scientific Linux 6.5 box using
>> binary and got this error when I tried to do ./configure...
>>
>> configure: error: OpenSSL not found.
>> even if I used ./configure --with-openssl=/usr/local/ssl
>
> Do you have the openssl-devel package installed?
>
>> So then I tried to install using Yum everything works fine if I run clamd as
>> root but if I switch it to run as clamav and start clamd this happens ...
>>
>> ERROR: Can't open/parse the config file /usr/local/etc/clamd.conf
>
> Where are you installing it from? EPEL has up-to-date clamav packages, but virtually no
> prebuilt packages should look in /usr/local. We've seen this before when clamd from a
> package links against libraries in /usr/local from a source installation.
>



More information about the clamav-users mailing list