[clamav-users] unable to install on Scientific Linux 6.5

Cliff Hayes chayes at afo.net
Mon Oct 13 15:12:29 EDT 2014


Thanks.
openssl-devel was not installed.
I installed and re-attempted binary installation.
I see the following 2 problems when using the following configure even 
though I told it where the bz2 and libcurl locations were:

./configure --with-xml=/usr/lib64 --with-libncurses-prefix=/lib64 
--without-libpdcurses-prefix --with-libcurl=/usr/lib64 
--with-libbz2-prefix=/lib64

checking how to link with libbz2... -lbz2
checking for BZ2_bzDecompressInit in -lbz2... no
checking bzlib.h usability... no
checking bzlib.h presence... no
checking for bzlib.h... no
configure: WARNING: ****** bzip2 support disabled

checking for libcurl installation... configure: WARNING: libcurl not 
found. Please use the web interface for submitting FPs/FNs.

Regarding your question about where did I install the yum package from:
I'm not sure which repo the package came from.
I have the following installed:
atrpms, elrepo, epel, epel-testing, rpmforge, sl6x, sl-other, sl


On 10/13/2014 10:30 AM, Bryan Burke wrote:
 > On Mon, Oct 13, 2014 at 10:19:13AM -0500, Cliff Hayes wrote:
 >> (I forgot to mention that OpenSSL is installed)
 >>
 >> I tried to install latest clamav on new Scientific Linux 6.5 box using
 >> binary and got this error when I tried to do ./configure...
 >>
 >> configure: error: OpenSSL not found.
 >> even if I used ./configure --with-openssl=/usr/local/ssl
 >
 > Do you have the openssl-devel package installed?
 >
 >> So then I tried to install using Yum everything works fine if I run 
clamd as
 >> root but if I switch it to run as clamav and start clamd this 
happens ...
 >>
 >> ERROR: Can't open/parse the config file /usr/local/etc/clamd.conf
 >
 > Where are you installing it from? EPEL has up-to-date clamav 
packages, but virtually no
 > prebuilt packages should look in /usr/local. We've seen this before 
when clamd from a
 > package links against libraries in /usr/local from a source installation.
 >



More information about the clamav-users mailing list