[clamav-users] clamav eating CPU since Friday

Steven Morgan smorgan at sourcefire.com
Mon Oct 27 12:22:44 EDT 2014


Hi Patrick,

Sounds like you probably have an infinite (or long running) loop, but I
would like to get a little more info. Are you running the latest version of
ClamAV? The latest is 0.98.4. You can tell with 'clamscan --version'. There
was a long running loop issue that was fixed in 0.98.4.

If you are already running 0.98.4, maybe we can try to reproduce the
problem with a debug version of ClamAV and attach the gdb debugger to
identify where is the problem? Running with debug messages turned on may
also provide some insight. You can do this by starting clamd from a
terminal window with the following options set in your clamd config file:

Foreground yes
Debug yes

Steve

On Mon, Oct 27, 2014 at 8:16 AM, Patrick von der Hagen <
patrick.hagen at kit.edu> wrote:

> Hi clamav-users,
>
> I'm running Debian with exim4-daemon-heavy using clamav as an
> antivirus-backend. It is basically the stock-debian installation. Clamav
> is not doing anything but checking emails.
>
> Usually clamav has little cpu-usage, but starting last Friday clamav
> goes to 100% cpu-usage on one core, later to 100% cpu-usage on another
> core, till all cores are busy running clamav at 100%.
>
> There have been no updates and no changes recently. The volume of
> messages has not increased. There might be some very strange emails sent
> to my systemor there might be an issue with recent signatures?
>
> Is there a way to revert to last Wednesdays signatures, so I can verify
> wheter or not it is related to my signatures?
>
> I'm really at a loss here. Any help would be greatly appreciated.
>
> --
> CU,
> Patrick.
>
>
> _______________________________________________
> Help us build a comprehensive ClamAV guide:
> https://github.com/vrtadmin/clamav-faq
>
> http://www.clamav.net/contact.html#ml
>



More information about the clamav-users mailing list