[clamav-users] Error (Cannot connect to unix socket '/var/lib/clamav/clamd.socket': connect: No such file or directory)

Reindl Harald h.reindl at thelounge.net
Sun Aug 7 11:12:22 EDT 2016



Am 07.08.2016 um 17:04 schrieb Alan Stern:
> On Sun, 7 Aug 2016, Chris wrote:
>
>> On Sun, 2016-08-07 at 10:49 +0200, Tobi wrote:
>>> It might a systemd issue. Have you tried to start clamd by calling it
>>> directly on cli? Does it create the socket then?
>>>
>>> Cheers
>>>
>>> tobi
>>
>> I've tried that lots of times Tobi, however, it still doesn't create
>> it:
>>
>> chris at localhost:~$ sudo service clamav-daemon stop  [ - ]  clamav-
>> daemon
>>
>> chris at localhost:~$ sudo service clamav-daemon start [ + ]  clamav-
>> daemon
>
> When systemd is installed, the "service" command is redirected to
> invoke systemctl.  To truly bypass systemd you would need to do
> something like "sudo /etc/init.d/clamav-daemon stop", etc.
>
>> The 'clamd.socket' file should be between these two but it's not:
>>
>> -rw-r--r--  1 clamav clamav    446464 Jun 23 11:40 bytecode.cld
>> -rw-r--r--  1 clamav clamav        82 Jul 13 14:44 crdfam.clamav.hdb
>
> This also could be caused by SELinux.  It can prevent files from being
> created even when all the permission settings are okay.  Have you
> checked the system logs for audit violations?
>
> Also, have you checked clamd's log file?

that and and on a smart setup /var/lib/clamd has a *readonly namespace* 
in the systemd-unit because it's asking for troubles let the software 
which deals by definiton with malicious code manipulate it's own 
signature files

hence lockfiles, pidfiles and sicketfiles belong to /run

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 181 bytes
Desc: OpenPGP digital signature
URL: <https://lists.clamav.net/pipermail/clamav-users/attachments/20160807/3a0d6b5b/attachment.sig>


More information about the clamav-users mailing list