[clamav-users] Problem with setup

Philip Andersson philip.andersson.ha at live.se
Tue May 24 08:58:19 EDT 2016


Well my internet messages is sent through the address and port that is in the config. So the file is sent from an url to clamd for virus check then forwarded if clamd does not report a virus. But the file ends up on the machine anyway. So i want it to scan files sent on the socket that clamd is listening on. 
 
Sorry for the confusion. 
 
> To: clamav-users at lists.clamav.net
> From: clamav at cosis.dk
> Date: Tue, 24 May 2016 14:49:18 +0200
> Subject: Re: [clamav-users] Problem with setup
> 
> 
> 
> On 05/24/2016 02:32 PM, Philip Andersson wrote:
> >   Hello clam users,
> >
> > I have a problem with my setup that creates a bit of a problem.
> >   
> > I have installed clamav99.2 with settings for my system from source, clamd runs fine with no error or warning output.
> > Database is up to date and freshclam runs.
> >   
> > The problem is that i tested the system with a fake virus, the virus got past the clamd running in the background and was not found until i did clamdscan on the file. Both clamd and clamdscan runs on the same .conf.
> >   
> > Is this normal? Why did it not find the virus in the stream data sent to clamd?
> >   
> > The virus was a fake-trojan implemented in .pdf.
> >   		 	   		
> > _______________________________________________
> > Help us build a comprehensive ClamAV guide:
> > https://github.com/vrtadmin/clamav-faq
> >
> > http://www.clamav.net/contact.html#ml
> Hi Philip,
> 
> Having the Clam Daemon running, doens't make it scan the activity on 
> your computer.
> 
> You need to configure eg. MTA or CIFS to send it's data through a 
> scanner - which in turn passes it through the Clam Daemon.
> 
> Best Regards
>    Michael
> _______________________________________________
> Help us build a comprehensive ClamAV guide:
> https://github.com/vrtadmin/clamav-faq
> 
> http://www.clamav.net/contact.html#ml
 		 	   		  


More information about the clamav-users mailing list