[clamav-users] Installation problem.

Gary R. Schmidt grschmidt at acm.org
Fri Dec 7 03:06:22 EST 2018


On 2018-12-07 18:28, nikos wrote:
> Hello list.
> 
> I'm trying to install the now version of clam and it seems to be
> compilation problems.
> 
> I run ./configure --sysconfdir=/etc --enable-milter in the programs
> folder and I get the error:
> 
> checking for g++... no
> checking for c++... no
> checking for gpp... no
> checking for aCC... no
> checking for CC... no
> checking for cxx... no
> checking for cc++... no
> checking for cl.exe... no
> checking for FCC... no
> checking for KCC... no
> checking for RCC... no
> checking for xlC_r... no
> checking for xlC... no
> checking whether the C++ compiler works... no
> configure: error: in `/home/admin/clamav-0.101.0':
> configure: error: C++ compiler cannot create executables
> See `config.log' for more details
> 
> I always install clam from source, as the previous versions. The funny
> thing is, if exctract and run configure in the previous version
> clamav-0.100.2 every works fine!
> 
> I have a server with latest centos release, full updated.
> 
> Any suggestions?
> 
Given that your command line works for me, and that your old version is 
fine, I suspect a problem with what you have downloaded, so try getting 
it again.

Anther thought is that you have run out of space in /home/admin.

And a third is just run configure without any options.

         Cheers,
                 Gary    B-)



More information about the clamav-users mailing list