[clamav-users] 99.3 for Ubuntu

Chris cpollock at embarqmail.com
Fri Jan 26 02:46:53 UTC 2018


On Fri, 2018-01-26 at 00:46 +0000, Scott Kitterman wrote:
> 
> On January 25, 2018 11:18:41 PM UTC, Chris <cpollock at embarqmail.com>
> wrote:
> > 
> > I'm trying to build 99.3 for Ubuntu 16.04LTS. I had no problems
> > building 99.2 with pbuilder. When downloading the source I got
> > 
> > pull-lp-source clamav
> > pull-lp-source: Downloading clamav version 0.99.3~beta1+dfsg-
> > 2ubuntu1
> > pull-lp-source: Downloading clamav_0.99.3~beta1+dfsg.orig.tar.xz
> > from
> > archive.ubuntu.com (5.611 MiB)
> > pull-lp-source: Downloading clamav_0.99.3~beta1+dfsg-
> > 2ubuntu1.debian.tar.xz from archive.ubuntu.com (0.207 MiB)
> > 
> > whereas with 99.2 I got the non-beta source files. I figured I'd go
> > ahead and build the beta, I could always upgrade to the non-beta
> > version. When attempting to build I got the errors shown here but
> > as I
> > pasted at the bottom of the paste file I have all the dependencies
> > listed:
> > 
> > https://pastebin.com/K1LfbwXX
> > 
> > I may have to post this to the ubuntu-users list but I'm hoping
> > someone
> > here can set me straight.
> From the pastebin:
> 
> Depends: llvm-3.9-dev
> 
> That's not available on 16.04.  Change it to the version that is
> available there (I don't track Ubuntu things anymore, so I don't know
> which one that is.
> 
> Scott K
Thanks for the reply Scott. According to this:

apt-cache policy llvm-3.9
llvm-3.9:
  Installed: 1:3.9.1-4ubuntu3~16.04.2
  Candidate: 1:3.9.1-4ubuntu3~16.04.2

apt-cache policy llvm-3.9-dev
llvm-3.9-dev:
  Installed: 1:3.9.1-4ubuntu3~16.04.2
  Candidate: 1:3.9.1-4ubuntu3~16.04.2

I noticed this in the README:

Additionally, we have introduced important changes and new features in
ClamAV 0.99.3, including:
    - Deprecating internal LLVM code support. The configure script has
changed to search the system for an installed instance of the LLVM
development libraries, and to otherwise use the bytecode interpreter
for ClamAV bytecode signatures. To use the LLVM Just-In-Time compiler
for executing bytecode signatures, please ensure that the LLVM
development package at version 3.6 or lower is installed. Using the
deprecated LLVM code is possible with the command: './configure --with-
system-llvm=no', but it no longer compiles on all platforms.

If I read the above correctly - 

To use the LLVM Just-In-Time compiler for executing bytecode
signatures, please ensure that the LLVM development package at version
3.6 or lower is installed. Using the deprecated LLVM code is possible
with the command: './configure --with-system-llvm=no', but it no longer
compiles on all platforms.

But then the pbuilder output says - Depends: llvm-3.9-dev

-- 
Chris
KeyID 0xE372A7DA98E6705C
31.11972; -97.90167 (Elev. 1092 ft)
20:20:34 up 12:21, 1 user, load average: 0.91, 1.54, 1.98
Description:	Ubuntu 16.04.3 LTS, kernel 4.13.0-31-generic
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 181 bytes
Desc: This is a digitally signed message part
URL: <https://lists.clamav.net/pipermail/clamav-users/attachments/20180125/da1059b5/attachment.sig>


More information about the clamav-users mailing list