[clamav-users] 99.3 for Ubuntu

Al Varnell alvarnell at mac.com
Fri Jan 26 03:18:33 UTC 2018


Are you sure you have the correct 0.99.3 download released late today from <http://www.clamav.net/downloads>?

That README only contains the following:

> 0.99.3
> ------
> 
> ClamAV 0.99.3 is a hotfix release to patch a set of vulnerabilities.
> 
>     - fixes for the following CVE's: CVE-2017-6418, CVE-2017-6420, 
>       CVE-2017-12374, CVE-2017-12375, CVE-2017-12376, CVE-2017-12377, 
>       CVE-2017-12378, CVE-2017-12379, CVE-2017-12380. 
>     - also included are 2 minor fixes to properly detect openssl install
>       locations on FreeBSD 11, and prevent false warnings about zlib 1.2.1#
>       version numbers. 
> 
> Thank you to the following ClamAV community members for your code
> submissions and bug reports! 
> 
> Alberto Garcia
> Daniel J. Luke
> Francisco Oca
> Sebastian A. Siewior
> Suleman Ali
> 
> Special thanks to Offensive Research at Salesforce.com for responsible disclosure.

-Al-

On Thu, Jan 25, 2018 at 06:46 PM, Chris wrote:
> 
> I noticed this in the README:
> 
> Additionally, we have introduced important changes and new features in
> ClamAV 0.99.3, including:
>     - Deprecating internal LLVM code support. The configure script has
> changed to search the system for an installed instance of the LLVM
> development libraries, and to otherwise use the bytecode interpreter
> for ClamAV bytecode signatures. To use the LLVM Just-In-Time compiler
> for executing bytecode signatures, please ensure that the LLVM
> development package at version 3.6 or lower is installed. Using the
> deprecated LLVM code is possible with the command: './configure --with-
> system-llvm=no', but it no longer compiles on all platforms.
> 
> If I read the above correctly - 
> 
> To use the LLVM Just-In-Time compiler for executing bytecode
> signatures, please ensure that the LLVM development package at version
> 3.6 or lower is installed. Using the deprecated LLVM code is possible
> with the command: './configure --with-system-llvm=no', but it no longer
> compiles on all platforms.
> 
> But then the pbuilder output says - Depends: llvm-3.9-dev



More information about the clamav-users mailing list