[clamav-users] Freshclam IPv6 error messages on IPv4-only systems

Walter H. Walter.H at mathemainzel.info
Wed Jul 4 09:42:27 EDT 2018


On 04.07.2018 15:00, Matt Vander Werf wrote:
> This has been mentioned at various points in several threads over the 
> past week or two (sometimes off-hand), but just wanted to somewhat 
> consolidate them here and also add my +1 to getting this bug addressed 
> in ClamAV soon!
>
> Per [1]:
>
> > This is a ipv4 site, and I occasionally get ipv6 error messages --
> > maybe 4 a week. They don't seem to cause any particular problem. A
> > freshclam.config option to disable ipv6 would fix that. Or maybe a
> > "protocol {ipv4|ipv6|any}" option.
just a hint
even if your host is IPv4 only, is IPv6 enabled and do you have a 
fe80::xxx address?
just try to really disable IPv6 at host/kernel layer
e.g.

this entry in /etc/sysctl.conf
net.ipv6.conf.eth1.disable_ipv6 = 1

disables IPv6 at port eth1 at all, there is no fe80:xxx address at this 
port ...

Walter

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.clamav.net/pipermail/clamav-users/attachments/20180704/229549ce/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 3491 bytes
Desc: S/MIME Cryptographic Signature
URL: <https://lists.clamav.net/pipermail/clamav-users/attachments/20180704/229549ce/attachment.bin>


More information about the clamav-users mailing list