[clamav-users] Malformed database issue

Jay Hart jhart at kevla.org
Sun Jul 15 17:05:28 EDT 2018


Hello and good afternoon,

Yessterday on a Centos 6.10 server I ran the software updater application which indicated 134
packages needed to be updated, one of which was Clamav.

The updater ran fine and the machine was rebooted. Upon reboot Clamav failed to run. This was due
to the deprecated option "AllowSupplementaryGroups" being enabled. Once I disabled this Clamav
would run, but I also was receiving a second error, which I have not been able to resolve.

It occurs when Freshclam queries the server for updated virus database files. I have enabled
logging for libclamav when freshclam runs to provide additional details.

ClamAV update process started at Sun Jul 15 16:27:39 2018
Using IPv6 aware code
Querying current.cvd.clamav.net
TTL: 611
Software version from DNS: 0.100.1
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.100.0 Recommended version: 0.100.1
DON'T PANIC! Read https://www.clamav.net/documents/upgrading-clamav
Retrieving http://db.local.clamav.net/main.cvd
Trying to download http://db.local.clamav.net/main.cvd (IP: 104.16.189.138)
Downloading main.cvd [100%]
LibClamAV debug: Initialized 0.100.0 engine
LibClamAV debug: in cli_cvdload()
LibClamAV debug: MD5(.tar.gz) = 57462fd73f1cfdb356b9dca66da2b732
LibClamAV debug: cli_versig: Decoded signature: 57462fd73f1cfdb356b9dca66da2b732
LibClamAV debug: cli_versig: Digital signature is correct.
LibClamAV debug: in cli_tgzload()
LibClamAV debug: in cli_tgzload_cleanup()
WARNING: [LibClamAV] cli_cvdload: Corrupted CVD header
LibClamAV debug: Cleaning up phishcheck
LibClamAV debug: Phishcheck cleaned up
ERROR: Verification: Malformed database
Querying main.0.91.0.0.6810BD8A.ping.clamav.net
Giving up on db.local.clamav.net...
Update failed. Your network may be down or none of the mirrors listed in /etc/freshclam.conf is
working. Check https://www.clamav.net/documents/official-mirror-faq for possible reasons.

NOTE: I just copied of the five tries for updating, they all show saw situation.

I am pointing to db.us.clamav.net as the country code.

Any idea how to resolve this?

Thanks,

Jay




More information about the clamav-users mailing list