[clamav-users] freshclam. Service exited with abnormal code: 1

Eric Tykwinski eric-list at truenet.com
Wed Nov 7 14:07:34 UTC 2018


Robert,

Looking at the freshclam return codes, it's not a problem.
https://github.com/Cisco-Talos/clamav-devel/blob/dev/0.101/freshclam/freshclamcodes.h

FC_UPTODATE = 1,

So basically it means there was no changes.

Sincerely,

Eric Tykwinski
TrueNet, Inc.
P: 610-429-8300

> -----Original Message-----
> From: clamav-users [mailto:clamav-users-bounces at lists.clamav.net] On
> Behalf Of Robert Chalmers
> Sent: Wednesday, November 07, 2018 5:24 AM
> To: clamav-users at lists.clamav.net
> Subject: [clamav-users] freshclam. Service exited with abnormal code: 1
> 
> I’m running freshclam on a Mac with a plist startup file, and although it
> appears to work at the required intervals, it always drops this error in the
> system.log
> "Nov  7 08:46:40 zeus com.apple.xpc.launchd[1]
> (org.homebrew.freshclam[85799]): Service exited with abnormal code: 1"
> 
> The odd thing is, it appears to work each time, but then gives this error when
> it exits.
> 
> I can not find the reason for this.
> 
> Thanks
> Robert
> 
> 
> 
> 
> 
> _______________________________________________
> clamav-users mailing list
> clamav-users at lists.clamav.net
> http://lists.clamav.net/cgi-bin/mailman/listinfo/clamav-users
> 
> 
> Help us build a comprehensive ClamAV guide:
> https://github.com/vrtadmin/clamav-faq
> 
> http://www.clamav.net/contact.html#ml





More information about the clamav-users mailing list