[clamav-users] Install error on Fedora 30

Cliff Hayes chayes at afo.net
Fri Aug 9 11:41:34 EDT 2019


I took advice given and used dnf to install clamd and clamav.
But now I am getting the errors:

WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.101.2 Recommended version: 0.101.3

I have tried dnf update clamd and dnf update clamav daily and there are 
no updates.

I looked at https://www.clamav.net/documents/upgrading-clamav
but there is no advice about this particular problem.

How do I get updates for a dnf installed clam?

On 7/23/2019 2:33 PM, J.R. via clamav-users wrote:
> Have you tried building without specifying the paths to see what it does?
> 
> There is a 0.101.2 RPM for FC30... Why not just modify the .src.rpm if
> you want to enable some custom options?
> 
> I believe you also need libxml2-devel last time I looked at the .SPEC
> for EPEL...
> 
> You can also try the following, though unless your openssl is
> installed in a custom directory it should find it in the standard
> paths...
> 
> CPPFLAGS=`pkg-config --cflags openssl`; export CPPFLAGS
> LDFLAGS="-Wl,-O1 `pkg-config --libs openssl`"; export LDFLAGS


More information about the clamav-users mailing list