[clamav-users] clamav-milter not being built for 0.102.0

lukn lukn555 at gmail.com
Wed Oct 2 16:17:15 EDT 2019


Hello list

Previous versions built perfectly, but on same build host 0.102.0 does
not build clamav-milter, but also does not show any obvious error
message as to why not.

Build hosts: Centos 6 (CentOS release 6.10 (Final)) and Centos 7 (CentOS
Linux release 7.6.1810 (Core)) - admitted, I should maybe update the C7
box to 7.7 first, but I highly doubt this will solve my problem. Clamav
0.101.4 was very happy to build clamav-milter on that very foundation.

configure is run as always, with the exception these ancient systems
won't support clamonacc out of the box. But as it is not needed I felt
it's safe to disable it:

./configure --prefix=/usr/local --enable-milter --disable-clamonacc
[..]
configure: Summary of optional tools
              clamdtop    : yes (-lncurses)
              milter      : yes ()
              clamsubmit  : yes (libjson-c-dev found at /usr)
              clamonacc   : no (disabled)

So configure claims it'll build my milter...

However, all make has to say about milter:
make: Nothing to be done for `all'.

What am I missing?

If my curl is too old, so is maybe make or gcc?
$ make --version
GNU Make 3.82
$ gcc --version
gcc (GCC) 4.8.5 20150623 (Red Hat 4.8.5-36)
but in such cases I'd expect a loud error message, compile abort yada
yada - not awkward output silence.

Any ideas? Any additional information needed?

Best regards
lukn


More information about the clamav-users mailing list