[clamav-users] Misleading error msg from "configure" when trying to build 0.102.0

Paul Kosinski clamav-users at iment.com
Mon Oct 7 16:55:32 EDT 2019


I was trying to build ClamAV 0.102.0 on a newish installation of Debian
10 (aka Buster), which was an "upgrade" from Deb 9. Doing aos also ran
in to the well known libcurl problem. But what shocked me was that,
after disabling the "on access" option, I got an error about OpenSSL:

  configure: error: Your OpenSSL installation is misconfigured or missing

So I spent a couple of hours trying to figure out which of the several
versions of OpenSSL were needed, and made sure the development
libraries were also there. But it still failed, even after I reinstalled
the packages.

So I tried building 0.101.2 on the same system, thinking it might be
a problem 0.102.0 had with the rather new Debian. But that failed in
the same way.

At that point I decided to look at the details of config.log, to see if
I could discover exactly what was wrong. It was then that I found that
gcc was failing on the "-lz" option, *not* on either the "-lssl" or
"-lcrypto" options. In particular:

  configure:17687: gcc -o conftest -g -O2   conftest.c   -lssl -lcrypto -lz >&5
  /usr/bin/ld: cannot find -lz
  collect2: error: ld returned 1 exit status

In other words, the output of configure was misreporting the problem as
being with OpenSSL, rather than what it really was (zlib).

So I installed zlib1g-dev (Debian's easy to remember package name) and
now it at least 0.101.2 (sic) configures, compiles and installs.

Paul Kosinski

P.S. I have updated libcurl and tried building 0.102.0 (even though I
don't really need on-access scanning). It turns out that Debian 10 has
a new enough version of libcurl available (7.64.0-4) so that works too. 


More information about the clamav-users mailing list