[clamav-users] Unable to compile 0.102.0 with fanotify support

Frans de Boer frans at fransdb.nl
Wed Oct 9 14:31:48 EDT 2019


On 09-10-2019 17:54, Arthur Ramsey via clamav-users wrote:
> Hello,
>
> I’m trying to compile 0.102.0 on Amazon Linux 2 but the configure 
> script isn’t detecting fanotify support:
>
> fanotify    : no (disabled)
>
> I have kernel-devel and glibc-headers installed.  I’ve also confirmed 
> fanotify support with "cat /boot/config-<kernel_version> | grep FANOTIFY”.
>
> I get an error from the configure script:
>
> ./configure: line 30024: auto=yes: command not found
>
> Here’s the full configure output: https://pastebin.com/0xYqhr2V.
>
> This was my attempt to fix it but it didn’t work: 
> https://pastebin.com/k2kCrmHP.
>
> I also tried latest on master and have the same issue.
>
> Thanks,
> Arthur
>
> _______________________________________________
>
> clamav-users mailing list
> clamav-users at lists.clamav.net
> https://lists.clamav.net/mailman/listinfo/clamav-users
>
>
> Help us build a comprehensive ClamAV guide:
> https://github.com/vrtadmin/clamav-faq
>
> http://www.clamav.net/contact.html#ml

Same as my complaint at October 3. Sofare no response other then making 
a bugzilla notion.

--- Frans.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.clamav.net/pipermail/clamav-users/attachments/20191009/b3c66bba/attachment.html>


More information about the clamav-users mailing list