On Tue, Jul 17, 2018 at 01:34 AM, Sergey wrote:
On Tuesday 17 July 2018, tschmidt wrote:

ClamAV 0.100.0 has been released!

 *   Deprecating internal LLVM code support. The configure script has changed to search the system for an installed instance of the LLVM development libraries, and to otherwise use the bytecode interpreter for ClamAV bytecode signatures. To use the LLVM Just-In-Time compiler for executing bytecode signatures, please ensure that the LLVM development package at version 3.6 or lower is installed. Using the deprecated LLVM code is possible with the command: ./configure --with-system-llvm=no, but it no longer compiles on all platforms.


Hm. But 3.x updated to 3.8 about 2 years ago.

That's the meaning of the word "deprecating".

Yes. But LLVM < 3.7 deprecated also.

No, deprecated refers to the use of LLVM greater than 3.6 by ClamAV 0.100.0, not LLVM itself.

-Al-
-- 
Al Varnell
Mountain View, CA